BlackLiquid Forums
Can't use Toolkit - Printable Version

+- BlackLiquid Forums (https://www.blackliquidsoftware.com/forum)
+-- Forum: Banished General (https://www.blackliquidsoftware.com/forum/Forum-Banished-General)
+--- Forum: Mod Makers Help & Support (https://www.blackliquidsoftware.com/forum/Forum-Mod-Makers-Help-Support)
+--- Thread: Can't use Toolkit (/Thread-Can-t-use-Toolkit)

Pages: 1 2 3


Can't use Toolkit - Karamile - 06-08-2018



I've downloaded the 1.0.7 toolkit from Shining Rock's website, and followed the instructions. However, when I try to run BuildResources.bat, it gives the following error: 

 




Assert: hr == D3D_OK && _device != NULL Failed to create D3D device!




Video\VideoDevice_dx9.cpp(296)




Callstack:

VideoDX9-x64-profile.dll(0x00000000f4bf7543) 

Runtime-x64-profile.dll(0x00000000e26de949) 

Runtime-x64-profile.dll(0x00000000e26b488b) 

Tools-x64.exe(0x000000003f233a80) 

Tools-x64.exe(0x000000003f3b47a3) 

kernel32.dll(0x00000000776759cd) 

ntdll.dll(0x00000000778d383d) 






I have tried updating my graphics driver, as that was suggested on other D3D device errors, however those were for attempting to run games, rather than a .bat - I couldn't find any info on this particular problem anywhere. 


I've also verified the game files, and yes, the game is also 1.0.7, and my OS is 64-bit. I have no further ideas on what's wrong. Maybe someone here can help? ^^





Can't use Toolkit - Ketchup - 06-08-2018


i guess you are with windows 10 ?




Can't use Toolkit - Karamile - 06-08-2018


Nope, Windows 7. I will 'upgrade' to 10 when I have no other choice...




Can't use Toolkit - Ketchup - 06-08-2018



ok then you should entirely be able to make it work !




 




first did you installed the 2 addons linked in the readme file ? :
https://www.microsoft.com/en-us/download/details.aspx?id=35 and https://www.microsoft.com/en-us/download/details.aspx?id=30679 ? and rebooted completly your computer after those 2 install ? (when you do your install, make sure to install as an administrator)




what is the path you did installed your toolkit ? there is absolutely no space no undescore no other strange caracter ? like : C:\Banishedkit\ or D:\BanishedKit\




did you copy pasted the 4 .pgk files in your C:\BanishedKit\Bin\WinData\ folder ? ( data0.pkg data1.pkg patch0.pkg patch1.pkg )





Can't use Toolkit - Karamile - 07-08-2018



Yes, DX said a newer version was already installed, I can't remember what the other one said - but I'll have a stab at reinstalling them just to be absolutely certain. 




I extracted it to E:\Installations\BanishedKit\, and did copy those four files ^^ I also tried C:\Banishedkit just in case it didn't like the custom location, but it didn't make a difference. 




 




ETA: C++ came up with the option to repair or uninstall, tried repair to make sure it wasn't corrupted, didn't help. Not sure if vcredist_arm is super crucial? Because I'm not sure what that one is for, but it says it's not a valid application when I try to run it, and I downloaded it twice in case it corrupted the first time





Can't use Toolkit - Ketchup - 07-08-2018



do you have 1 graphic card or 2 ? (like 1 card and 1 gpu on the motherboard. it is a pc or a portable ?)




maybe try to uninstall your direct x and reinstall the one from the link. your error is about directx 9 (the directx 11 is newer... but you need an install of directx 9 too)




 




 




about the arm.exe.. i dont think it is one to download, VSU_4\vcredist_x64.exe should be your target for your pc





Can't use Toolkit - Karamile - 07-08-2018



Desktop, I think there is a basic integrated gpu but I use the card. 




Do you have directions on how to uninstall directx? Googling it has me concerned and confused 





Can't use Toolkit - Ketchup - 07-08-2018


Quote:
49 minutes ago, Karamile said:




Desktop, I think there is a basic integrated gpu but I use the card. 




i think thats the major part of your problem. probably some direct parts are linked to your integrated gpu and when the tools try to use it, it gets some errors.




 




first try a right click on your "My computer" icon and select properties. a window will open. at the left, click on the link: Device Manager. another window will open and check for: Display adapter




click on the arrow > to list them and check if 2 display adapter are displayed. if both (card and integrated) are showing up, spot the integrated one and right click and choose deactivate.




 




maybe a reboot is needed... dont know.




check your toolkit if still doesnt work maybe a forced reinstall of directx is necessairy.




 




directx doesnt have an uninstall feature.




press the windows menu keyboard button (or with mouse click at bottom left Start button) to open the windows menu bar. there is a little box at bottom. inside it type regedit.




it should find regedit.exe. click on it accept the launch. follow the arrows to surf inside the folders tree: HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > DirectX




inside DirectX there are 3 values to the right of the windows : double click on "version" a little window will appear with that number: 4.09.00.0904. replace the first "9" by an "8" (4.08.00.0904)




close everything and then launch the directX installer.




 




hopefully it will resolve your problem by being sure directx know there is only 1 video card and ignore there is an integrated gpu.





Can't use Toolkit - Ketchup - 07-08-2018



oh and if happends you turned OFF your real video card.... ^^ and dont have anymore any screen... ^^




your will probably have to reboot your PC with reset button and boot your windows 7 in "Safe mode" by pressing many many times F8 to trigger the boot windows menu > safe mode. then there to can re-enable your video card [img]<fileStore.core_Emoticons>/emoticons/biggrin.png[/img]/emoticons/biggrin@2x.png 2x" title=":D" width="20" />




Can't use Toolkit - Karamile - 07-08-2018



Okay, I disabled the integrated graphics, and did the regedit thing, but the DX installer still only gives the option to repair or uninstall. I tried restarting as well, and that didn't change anything. The value in the registry is still 4.08.00.0904. 




 




And I was very careful to disable the correct one [img]<fileStore.core_Emoticons>/emoticons/wink.png[/img]/emoticons/wink@2x.png 2x" title=";)" width="20" />