Updated but now the Roads hang

The <abbr title="Colonial Charter">CC</abbr> Journey Mod updated today and whenever I try to build a road, the screen becomes really laggy (I have tried different types of roads and they also hang). Although I click on other icons, say a building, the road "cursor" still appears for a short while afterwards.  Before the update everything worked fine. Thanks great Mod!

And I'm on a laptop if you are interested in that information


Unfortunately, I'm not able to duplicate this issue so we cannot pinpoint the cause of this issue. We would love to hear from others if they are also having the same problem.  


Thanks for your reply! I downloaded the Mod again(Steam Workshop) but it is still happening unfortunately. If I pause the game and build roads it works fine so it may be due to the processing power of my crappy laptop. Everything worked fine up until yesterday where it updated when I checked if there were any other Mods running. No other Mods were running(Disabled) at the time.