Merchants don't come again
#1
Question 
Playing with CC 1.76
I built 3 trading post (1 Dock Trading Post, 1 Trading Post, 1 Food Supplies), merchants used to come and stop regularly
but then suddenly they never come again, the merchant ships show up sometimes, but just go along with the stream and coast and never go and stop at my posts

I tried removing the quartermaster (the situation came after i built this one) but no effect. 
I tried assigning some villagers to be traders but not work. 
I also demolished and rebuilt it in same place, not work at all.
I even built a new one in other place but nothing was happening....

Any solution to deal with it? 




Yellow line was the the routes they used to come for stopping, but now they turned to go like the red line
Shy


Attached Files Thumbnail(s)
       
  Reply
#2
you probably created a block somewhere. the game may have delayed the affect so merchants came after for a short time. from the pic i would try terraforming out the dirt by the bridge. you coud try removeing the bridge or build another trade post along the main river.
  Reply
#3
(09-09-2019, 01:20 AM)stiles Wrote: you probably created a block somewhere. the game may have delayed the affect so merchants came after for a short time. from the pic i would try terraforming out the dirt by the bridge. you coud try removeing the bridge or build another  trade post along the main river.

I tried removing some bridges to see any changes and then i found this set of bridges was the suspect...

The dock bridges could be removed and merchants came and stopped again,
but when i tried to demolish the dock rail, it crashed...

what should i do to remove those dock rail without crash?


Attached Files Thumbnail(s)
       
  Reply
#4
Unfortunately I can't duplicate the problem - I tried building a dock bridge with rails and was able to delete them without crashing. The only thing I can think of is that you may be using a different version of MegaMod. Are you using MegaMod 8.01 with Banished version 1.07 - build 170910?
  Reply
#5
(10-09-2019, 03:03 AM)estherhb Wrote: Unfortunately I can't duplicate the problem - I tried building a dock bridge with rails and was able to delete them without crashing.  The only thing I can think of is that you may be using a different version of MegaMod.  Are you using MegaMod 8.01 with Banished version 1.07 - build 170910?I

I am playing CC 1.76 with Banished version 1.07 -build 170910
  Reply
#6
I tried CC 1.76. Again, I didn't have any problem deleting the rails to the dock bridge. I clicked on the rails, a window appears with a trash can with an X. Clicked on the X and the rails disappeared. Sorry that I can't help you figure out why you are getting crashes when you try that.
  Reply
#7
(10-09-2019, 04:43 AM)estherhb Wrote: I tried CC 1.76. Again, I didn't have any problem deleting the rails to the dock bridge.  I clicked on the rails, a window appears with a trash can with an X. Clicked on the X and the rails disappeared.  Sorry that I can't help you figure out why you are getting crashes when you try that.

I just tried to remove all things around the bridges and rails
and then same situation occurred when the demolition progress of the roadless well at over 100% (at 105%)


Attached Files Thumbnail(s)
   
  Reply
#8
How large of a map are you using and what speed are you on?
  Reply
#9
(10-09-2019, 05:25 AM)estherhb Wrote: How large of a map are you using and what speed are you on?

I am using a [CC] Very Large [CC] Lake Waters map. The Map Seed is 160262289.

Usually play on x2 speed
  Reply
#10
I really don't know why your map is doing this. It's not normal for anything to demolish over 100%. Checked with Kralyerg and he is also at a loss. There are more issues with the biggest maps, especially when populations are high. It's like the AI just can't keep up (that's why I wondered what speed you are using). Sounds like you've already exited the game then gone back in and that didn't clear things. Sorry we don't have a fix for you.
  Reply