I'm trying to download Colonial Charter, an Mega Mod.But its not letting me. I don't have a steam account. Google drive not letting me. What can i do...
GoogleDrive usually gives a warning because of hos large the file is. If you look around on the page (usually at the top I think), you should see a "download anyway" kind of link that you can click on to start the download.
Tried that didn't work..
Do you get error messages? Does the download simply refuse to start, or do you end up with a corrupted file?

I just tried it. I had to click twice on a kind of "download anyway" button because of warnings that first there's no preview, and second the file is too large so can't be analysed by antivirus. After that the download works normally for me.

I guess it could be a few things: your browser or internet connection settings restricting what you can or can't download based on file size, or an antivirus blocking things it can't download. If you can't start the download, check your browser's / connection settings to check there's no limit on file size, or try using a different browser.

The file is huge, so if your connection doesn't have good quality, you could have errors during the download. If your computer goes into Sleep mode because you're letting it download while doing something else, it could be failing to restart correctly. So if you manage to download something but it's corrupted, you could try to temporarily change your connection's setting to "slow but fewer errors", disable sleep mode and see if you can get the dowload to work better that way.