The following warnings occurred:
Warning [2] session_start(): open(/opt/alt/php73/var/lib/php/session/sess_f90aa013084184aa5d61dd8f1fdafd96, O_RDWR) failed: Disk quota exceeded (122) - Line: 415 - File: inc/plugins/myfbconnect.php PHP 7.3.20 (Linux)
File Line Function
[PHP]   errorHandler->error
/inc/plugins/myfbconnect.php 415 session_start
/inc/class_plugins.php 142 myfbconnect_global
/global.php 100 pluginSystem->run_hooks
/showthread.php 28 require_once
Warning [2] session_start(): Failed to read session data: files (path: /opt/alt/php73/var/lib/php/session) - Line: 415 - File: inc/plugins/myfbconnect.php PHP 7.3.20 (Linux)
File Line Function
[PHP]   errorHandler->error
/inc/plugins/myfbconnect.php 415 session_start
/inc/class_plugins.php 142 myfbconnect_global
/global.php 100 pluginSystem->run_hooks
/showthread.php 28 require_once




Banished crashing when upgrading Tailor to Clothier
#1

Not sure what causes this, it just seems to happen. I can still build the other higher tier clothing building but i like the astetic of the clothier. The crash dump file (least im guessing thats what it is) is nothing but a bunch of garbage hex stuff if you want me to provide it i will.

  Reply
#2

Problems like this are usually caused by a conflict of some sort. Which mods and versions are you using, and in what order? Are you using Banished version 1.0.7?

  Reply
#3


In order


Blacksmith Tools




<abbr title="Colonial Charter">CC</abbr> Terrain Tools




Covering




D20 Midieval Houses




Happiness Radius




Unhappiness Radius




More Stable Populations




Statue Plus




<abbr title="Colonial Charter">CC</abbr>:1.76




Canal




DS Fences and Decorations




Grass Guardian




DS Jetty & Bridge




DS Bridge Crossing




DS Globe Theater




DS Roads




DS Terrains and CLimates




DS Thompson Trade Merchants




DS Timber Mill




DS Tunnels




DS Wagon Vendor




RK Editors Choice - Full




RK Midieval Town Ver 2.04.1




Styth Tower




DS Stone Bridge




 




And yes im on 1.0.7


  Reply
#4


We are seeing a number of people who are using a large variety of mods, some old and some new, who are complaining of crashes and/or bugs. The problem is, it is impossible for us to determine which mod or mods are creating the problem.  That's because the only real way to do that is to start with your base mod (<abbr title="Colonial Charter">CC</abbr>?) and add one mod at a time until you see an issue.  




I tend to have very good luck using mods by DS and Red Ketchup, but here's a few things you could try:




RK's Medieval Town 2.04.1 has not been updated for use with Banished 1.0.7. Many of those buildings, such as the 3-story houses and the Canals (you're using a separate mod) are included in his Editors' Choice mod. You should delete Medieval Town and Canals.




There's one person I saw on Steam who has reported an issue when using the More Stable Populations mod. You could try deleting that too.  




Try deleting Grass Guardian - it's old and some of these older mods have surprise affects.




 


  Reply
#5

Quote:
7 hours ago, estherhb said:




We are seeing a number of people who are using a large variety of mods, some old and some new, who are complaining of crashes and/or bugs. The problem is, it is impossible for us to determine which mod or mods are creating the problem.  That's because the only real way to do that is to start with your base mod (<abbr title="Colonial Charter">CC</abbr>?) and add one mod at a time until you see an issue.  




I tend to have very good luck using mods by DS and Red Ketchup, but here's a few things you could try:




RK's Medieval Town 2.04.1 has not been updated for use with Banished 1.0.7. Many of those buildings, such as the 3-story houses and the Canals (you're using a separate mod) are included in his Editors' Choice mod. You should delete Medieval Town and Canals.




There's one person I saw on Steam who has reported an issue when using the More Stable Populations mod. You could try deleting that too.  




Try deleting Grass Guardian - it's old and some of these older mods have surprise affects.




 




Is there a direct replacement for More Stable Populations? Ive grown attached to it greatly. As far as Medieval town, Yeah i actually spoke with RK on reddit the other day and he assured me he was porting it into his editors choice which i am super excited about! Ill delete those as I know ill be getting them back in the near future. 




 




 


  Reply
#6

Quote:
8 hours ago, estherhb said:




We are seeing a number of people who are using a large variety of mods, some old and some new, who are complaining of crashes and/or bugs. The problem is, it is impossible for us to determine which mod or mods are creating the problem.  That's because the only real way to do that is to start with your base mod (<abbr title="Colonial Charter">CC</abbr>?) and add one mod at a time until you see an issue.  




I tend to have very good luck using mods by DS and Red Ketchup, but here's a few things you could try:




RK's Medieval Town 2.04.1 has not been updated for use with Banished 1.0.7. Many of those buildings, such as the 3-story houses and the Canals (you're using a separate mod) are included in his Editors' Choice mod. You should delete Medieval Town and Canals.




There's one person I saw on Steam who has reported an issue when using the More Stable Populations mod. You could try deleting that too.  




Try deleting Grass Guardian - it's old and some of these older mods have surprise affects.




 




Well i figured out that RK's Editors choice is the thing that is exclusively messing with my ability to upgrade the tailor to the clothier. I am unsure of where to go from here as I wanted both of them to work together.


  Reply
#7


Try this.




<a class="ipsAttachLink" href="<___base_url___>/applications/core/interface/file/attachment.php?id=3108" data-fileid="3108">CCECPatch.pkm</a>




Put it above both <abbr title="Colonial Charter">CC</abbr> and EC.




It's a quick and dirty little thing I made. But it's also untested, so save your game before you try this.  Assuming I did everything correctly, it should fix the problem with the Tailor/Clothier upgrade.


  Reply