Banished Crash after launching a session with MegaMod
#1
I don't know what's going on, I'm no expert in computer things, but there's a crash every time I use MegaMod and it only happens when I try to launch a session, it tells me there's some kind of "Violation" and tells me to check the crash dump

I tried opening the crash.dmp file in Notepad but I got gibberish. How do I figure out how to fix my game? This was the original issue of why I stopped playing the game in the first place. Can someone explain to me what I'm supposed to do?

Forgot to add the crash.dmp file to my above post, doing it now so someone can explain what I'm doing bad so the game wrecks itself


Attached Files
.zip   crash.zip (Size: 88.3 KB / Downloads: 0)
  Reply
#2
Please verify that you are using Banished v. 1.0.7 - Build 170910 and MegaMod 8.01. Please verify that you are only using the 3 MM files in your game and that they are in 1, 2, 3 order and all are red. If you are using any other mods, let me know what they are and whether they are above or below MM. Thanks. Also, what is the exact wording of the violation?
  Reply
#3
I have updated to 1.0.7, but I don't know how to change builds, how would I do that?
  Reply
#4
The build comes with the most current version of 1.0.7.
  Reply
#5
i have verified if the mod files were read only and they aren't, I have no other mods than MM 8.01, they are loaded in order from 1being at the top 2 in the middle and 3 at the bottom. I have verified the Game Cache and nothing is missing. I tried switching Direct X version, still had a problem with Access Violation. You're talking about game build, where do i change it to the appropriate version?
  Reply
#6
A copy of the most up-to-date version is usually available from where ever you bought your game. My copy is from Steam and it gets updated automatically. Where did you buy yours?
  Reply
#7
I set the game to the beta 1.0.7 but there's still crashing issues. is it because I'm runnign the game on x32 bit or does steam use x64bit? I have a x64 bit computer, maybe its trying to run 32bit and it crashes because of it. Or is there something I don't know about installing the mods, maybe a step i didnt do because there is no guide on how to install the mods, just a link and no instructions anywhere i looked. Last time i tried playing this game, a year or so ago, i had the very exact same problem.

i want to know exactly what are EACH STEP TO PROPER MOUNTING AND INSTALLATION please.

also is there a Discord of some kind for this community? I want to be able to have someone to talk to me through the process in real time. this is aggravating me.
  Reply
#8
If the 3 MM files are appearing in the mod list of your Banished game, then you must have downloaded the .RAR file, unzipped it into the 3 .pkm files and put those 3 files in your Banished > WinData folder. When you make any changes to your list of mods (check or uncheck) be sure to exit the game completely then go back in and start a new game. Have you tried starting a new game using the updated version of Banished?

BTW, mine is a 64X bit computer and MM runs just fine.

I don't use Discord.
  Reply
#9
I have no previously saved game, so I'm trying to make a fresh one. I apply the settings I want and then start up the game, then once the game is loaded, it shows me the main menu, i go to start a fresh session but during loading, it crashes due to "Access Violation" What the heck is going on?
  Reply
#10
what "process" do you want us to walk you through? You've already downloaded the RAR, unzipped the 3 pkms and put them in your Banished > WinData folder. At this point, sounds like you have a conflict with something else. Exactly what does the error message say???

You can try loading Colonial Charter 1.76 instead of MM and see if you have any problems with that. The easiest way is to subscribe to it from the Steam Workshop. Just be sure to uncheck the MM folders. When you make changes to your mod list, be sure to exit the game completely before starting a new game.

I did a search on "Banished Access Violation" and came up with this thread from Steam's Banished Discussions. Please take a look and see if this helps.  https://steamcommunity.com/app/242920/di...308768200/
  Reply